Ticket #3933 (closed defect: duplicate)

Opened 15 months ago

Last modified 15 months ago

Missed useful checkbox "Search for content" in "Find File" dialog

Reported by: nrbrtx Owned by:
Priority: major Milestone:
Component: mc-search Version: 4.8.19
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Steps to reproduce:

  1. Install Midnight Commander on modern Ubuntu 18.04 LTS
  2. Open "Find File" dialog (I do this with F9-c-f many times during workday)
  3. In "Content" zone try to find "Search for content" checkbox for doing search inside files

Expected results:

  • "Search for content" checkbox is available in MC.

Actual results:

  • "Search for content" checkbox is missed in MC.

Scenario when "Search for content" is useful:

  • When doing many searches in day they can differ by options. Some may we ran only for "File name", but some may require search for "Content". So in 16.04 LTS it was very useful to have "Search for content" checkbox. If user need to do search inside files, he check it (and last text value is remembered in it). If user does not want to search for content, he unchecks the checkbox.
  • But with new behavior (without "Search for content") user is forced to clear this field.

Please bring "Search for content" checkbox back.

Link to launchpad bug-report - https://bugs.launchpad.net/bugs/1787808

Change History

comment:1 Changed 15 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3680.

Note: See TracTickets for help on using tickets.