Ticket #3903 (closed enhancement: duplicate)

Opened 21 months ago

Last modified 5 months ago

"Natural" mouse scroll direction

Reported by: vik Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Please add the "natural scroll direction" feature to scroll with mouse using natural scroll direction as it is done in the macos.
It could be done in 10-15 minutes by adding new boolean parameter in the CONFIG_MISC_SECTION, for example "mouse_reverse_scroll", loading it in the setup.c, and then to change mouse.c by reversing the mouse scroll direction if it's set, like:

midnight/mc/lib/widget $ diff mouse.c mouse.c.original
104,107c104
< if (mouse_reverse_scroll)
< msg = MSG_MOUSE_SCROLL_DOWN;
< else
< msg = MSG_MOUSE_SCROLL_UP;
---

msg = MSG_MOUSE_SCROLL_UP;

109,112c106
< if (mouse_reverse_scroll)
< msg = MSG_MOUSE_SCROLL_UP;
< else
< msg = MSG_MOUSE_SCROLL_DOWN;
---

msg = MSG_MOUSE_SCROLL_DOWN;

All Mac users will say you big "thank you" for that ))

Change History

comment:1 Changed 21 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #3902.

comment:2 Changed 5 months ago by zaytsev

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.