Ticket #3893 (closed enhancement: fixed)

Opened 11 months ago

Last modified 7 months ago

New markdown syntax highlighting doesn't play well with complex files.

Reported by: sknaumov Owned by:
Priority: major Milestone: 4.8.21
Component: mcedit Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset: committed-master

Description

Syntax highlighting from #3864 doesn't play well with lists or words containing underscores. And given that markdown files could contain not only ASCII text, it is better to be conservative in detecting contexts.
Otherwise syntax highlighting looks like a Christmas tree, but with toxic colors, forcing me to turn it off at all.
Proposed fix is attached.

Attachments

0001-syntax-fix-markdown.syntax-that-doesn-t-work-well-fo.patch (1.3 KB) - added by sknaumov 11 months ago.
Proposed fix

Change History

Changed 11 months ago by sknaumov

Proposed fix

comment:1 Changed 11 months ago by sknaumov

  • Component changed from mc-core to mcedit

comment:2 Changed 11 months ago by andrew_b

Ticket #3894 has been marked as a duplicate of this ticket.

comment:3 Changed 7 months ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset set to committed-master
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.