Ticket #3881 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

broken syntax highlighting of bash

Reported by: xmlich02 Owned by:
Priority: major Milestone:
Component: mcedit Version: 4.8.19
Keywords: highlighting Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

By the way, the trac version combobox doesn't allow selection of '4.8.20'.

Create an bash script:
#!/bin/bash
echo "hello world"
res="$(ls "-1" "$(pwd)")"
echo "hello world"

Second hello world is highlighted incorrectly. You can compare highlighting with vim or other editor as well. See attached screenshot

[jmlich@jmlich-dell Desktop$ mcedit -V
GNU Midnight Commander 4.8.20
Built with GLib 2.48.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;
[jmlich@jmlich-dell Desktop$ mcedit ./highlight.sh

Attachments

highlight.sh (76 bytes) - added by xmlich02 2 years ago.
reproducer
highlight.png (44.7 KB) - added by xmlich02 2 years ago.
screenshot

Change History

Changed 2 years ago by xmlich02

reproducer

Changed 2 years ago by xmlich02

screenshot

comment:1 Changed 2 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2142.

Note: See TracTickets for help on using tickets.