Ticket #3875 (closed defect: duplicate)

Opened 21 months ago

Last modified 2 months ago

Verify basic file properties before reusing cached contents

Reported by: egmont Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc: howaboutsynergy@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by egmont) (diff)

From https://bugzilla.redhat.com/show_bug.cgi?id=1516219 (haven't verified but sounds plausible):

vfs cache should store and later verify that some basic properties of the file (size, mtime, inode? - or maybe checksum?) haven't changed, and only then reuse the cached entries. Otherwise ignore them and recache.

Change History

comment:1 Changed 21 months ago by egmont

  • Description modified (diff)

comment:2 Changed 21 months ago by andrew_b

Actually duplicate of #62 or #2454.

comment:3 Changed 21 months ago by egmont

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #62.
Oh, indeed. Sorry for the noise!

comment:4 Changed 20 months ago by zaytsev

  • Milestone Future Releases deleted

comment:5 Changed 2 months ago by howaboutsynergy

  • Cc howaboutsynergy@… added
Note: See TracTickets for help on using tickets.