Ticket #3854 (closed enhancement: duplicate)

Opened 2 years ago

Last modified 2 years ago

Typing on keyboard filters the file list

Reported by: allanbj76 Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: quick filter Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Something that will be super useful and speed up navigating the file system tremendously is making it possible just start typing on the keyboard and the file and folder list you are currently in will automatically be filtered to only show items that contain the text you are typing. Everything else should stay just the same.

On the similar Windows version "Total Commander" I do this all the time and can navigate extremely quickly. To cancel the filter I press Escape in order to show all items again - and the filter is of course reset every time you go to a new filter.

I realize this should be a feature you can easily turn on and off since some might want to retain current behaviour where you type a command when you start typing.

Change History

comment:1 Changed 2 years ago by andrew_b

  • Milestone changed from 4.8.20 to Future Releases

comment:2 Changed 2 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2697.

Note: See TracTickets for help on using tickets.