Ticket #3844 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Viewer displays invalid UTF-8 characters >127 <256 as corresponding Unicode codepoints

Reported by: zaytsev Owned by: zaytsev
Priority: major Milestone:
Component: mcview Version: 4.8.19
Keywords: Cc: egmont
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

While looking into #3843, it seems that I have found another weird bug: invalid UTF-8 characters >127 <256 are displayed incorrectly as corresponding Unicode codepoint in viewer, but they are treated correctly in editor and in hex mode.

Attachments

mc-viewer-invalid.png (12.4 KB) - added by zaytsev 3 years ago.
mc-editor-correct.png (10.2 KB) - added by zaytsev 3 years ago.
mc-viewer-hex-correct.png (28.3 KB) - added by zaytsev 3 years ago.

Change History

Changed 3 years ago by zaytsev

Changed 3 years ago by zaytsev

Changed 3 years ago by zaytsev

comment:1 Changed 3 years ago by zaytsev

FYI, I'm observing this under UTF-8 locale. Egmont, you are the viewer guru, aren't you, maybe you might have an idea?

comment:2 Changed 3 years ago by egmont

Is this a dupe of #3783 or a different problem (i.e. does the fix to that one, or current git fix this one also)?

comment:3 Changed 3 years ago by zaytsev

  • Owner set to zaytsev
  • Status changed from new to accepted
  • Milestone changed from Future Releases to 4.8.20

Oh, stupid me, trying on 4.8.19, instead of current git. Will check again and report back, thanks!

comment:4 Changed 3 years ago by zaytsev

  • Status changed from accepted to closed
  • Version changed from master to 4.8.19
  • Resolution set to duplicate
  • Milestone 4.8.20 deleted

Closed as duplicate of #3783.
Just checked with master this morning, and it was indeed fixed in the meantime! Maybe time to think about reviewing the cleanup branch and making another release soon no matter what. When one starts finding bugs fixed in master, it sounds like a hint... Thank you, Egmont!

Note: See TracTickets for help on using tickets.