Ticket #3808 (closed defect: invalid)

Opened 3 years ago

Last modified 23 months ago

visible tabs options identation hide the cursor

Reported by: mckaygerhard Owned by:
Priority: major Milestone:
Component: mcedit Version: master
Keywords: cursor hidden visible Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

inside the editor mode, in the ident part, the cursor does not show if the visible tabas or visible spaces are active--

the cursor does not show and if many tabs are in, the cursor position does not show until are out of the tabs ...

Change History

comment:1 Changed 3 years ago by andrew_b

  • Priority changed from critical to major
  • Milestone changed from 4.8.20 to Future Releases

What terminal emulator do you use?

For reference: #113

comment:2 Changed 3 years ago by andrew_b

  • Summary changed from visible tabas options identation hide the cursor to visible tabs options identation hide the cursor

comment:3 Changed 3 years ago by mckaygerhard

i not use a only terminal.. various.-..

i just migrated the two linux boxes, firts i used two: debian etch and geento, very olders..

then i migrated to debian jeesie/sid and alpine linux..

no care what terminal i used, always cursor dissapear .. in debian etch this not happened before recent versions of "mc", the mc version used in etch was 4.6.1, now with 4.8.15 the behaviour changed very...

just for test, i understand u'r question, and its not related to vte, i explain:

1) i used the same putty terminal at guindows (never was updated)
2) i updated the "mc" software due updated the "linux" sistems
3) so then the only change here its the "mc", not the "terminal"
4) the problem its then no in the terminal, due with etch there's no problem

the most used for me are the putty terminal (either in linux or guindows, always remotelly)

before version 4.6.2 that problem never happened! I REPEAT the terminal are the same, putty! never updated the version in the ruindows..

comment:4 Changed 3 years ago by andrew_b

Windows is not supported.

I have linux putty 0.68 and when I connect to localhost, mc works fine. Cursor is visible.

comment:5 Changed 3 years ago by mckaygerhard

in linux putty also happened, also in sakura.. the cursor only are visible in the xterm and the problem its the color, its too similar to the background..

i already read all the #113 issue, see the patches.. seem i used a version that still have the problem, in witch version this patches where included?

i rebuild the 4.8.19 and i noted now the cursor but only few.. i mean its not noted at all.. theres a option to the cursor mantain its own color?, witch patch fixed the problem i dont understand very much the #113 threath complety

since 4.6.1 ther's not much confortable this behabior

comment:6 Changed 23 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.