Ticket #3807 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Midnight Commander 4.8.19 Keyboard Regression

Reported by: Axanar Owned by:
Priority: critical Milestone:
Component: mc-tty Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hello

I would like to inform, that there is a keybinding regression inside mc-4.8.19, that I reported to Fedora today (They put a new release in the repository).

https://bugzilla.redhat.com/show_bug.cgi?id=1440110

Let me explain:

I've been using mc since it came out (with other words: many many years). It's one of my main tools that I regulary and intensively use. And as you may guess, most keyboard shortcuts are memorized (at least the ones I use). Till mc-4.8.18 everything worked but with mc-4.8.19 keybindings have changed...

Example:

When mc starts, the usual keybindings are (sorry if I name them wrong)

F5 = Copy
F6 = Move
Shift+F5 = Copy As
Shift+F6 = Move As

With 4.8.19 they have changed.

F5 = Copy
F6 = Move
Shift+F3 = Copy As
Shift+F4 = Move As
Shift+F6 = Delete (if you have confirm delete disabled then everything will be wiped)

Previous Shift+F3 and Shift+F4 functionality are overwritten (usually Shift+F3 opens internal editor).

I strongly believe, that this is a regression and like to have it fixed to the behaviour it had before.

I also consider this quite critical because of the expected behaviour that Shift+F6 usually have a popup (dialog) coming up, where you can change paths or filenames...

With the current behaviour you could accidently remove all your files and directories because Shift+F6 reflects to "delete" now, if you have the said confirmation flag inside the preferences disabled (delete without feedback).

Running Fedora, Xorg, XFCE-4.12

Downgrading to mc-4.8.18 solves the issues. So it must be a regression somewhere the transition to mc-4.8.19.

Btw: This issue also exists (for years) if you switch to Console. Copy and Move are incorrectly placed to F3 and F4 rather than F5 and F6 (as even the Keybar tells). So what affected Console for years now also affects mc when running under Xorg within a terminal.

Change History

comment:1 in reply to: ↑ description Changed 3 years ago by andrew_b

Replying to Axanar:

When mc starts, the usual keybindings are (sorry if I name them wrong)

F5 = Copy
F6 = Move
Shift+F5 = Copy As
Shift+F6 = Move As

With 4.8.19 they have changed.

This is impossible. There no any such changes made in mc.

F5 = Copy
F6 = Move
Shift+F3 = Copy As
Shift+F4 = Move As
Shift+F6 = Delete (if you have confirm delete disabled then everything will be wiped)

Everything used fine for me for years.

Downgrading to mc-4.8.18 solves the issues.

This is very strange.

So it must be a regression somewhere the transition to mc-4.8.19.

I can't agree.

Btw: This issue also exists (for years) if you switch to Console. Copy and Move are incorrectly placed to F3 and F4 rather than F5 and F6 (as even the Keybar tells). So what affected Console for years now also affects mc when running under Xorg within a terminal.

#3254

comment:2 Changed 3 years ago by Axanar

Ok I did the following:

I've set up an development environment on my system. Everything needed to build mc on Fedora.

dnf builddep mc
dnf install gcc make autoconf automake libtool gettext slang-devel

Then I downloaded mc-4.8.18.tar.bz2, ran configure --prefix=/usr, make, make install.

Works as expected!

Then I downloaded mc-4.8.19.tar.bz2, ran the same arguments as above.. but removed 4.8.18 before.

Works as expected! No issues, as I initially reported...

But!

http://pkgs.fedoraproject.org/cgit/rpms/mc.git/commit/?id=589373c36dbfe5fddd1e5a187cc60b7580c9ade9

The Fedora devs seem to have changed from using slang to using ncurses now...

So I just recompiled 4.8.18 again (the usual stuff, removing old installation and then the above parameters again).

Fails! With NCurses the issues as described by me shows up. I don't think I need to recompile 4.8.19 with NCurses then.

So this is a NCurses or underlaying specific issue as described in the bugreport.

#3254

Now.... How to solve this issue ? And what would be the proper answer that I can give within the Fedora bugreport so the Fedora developers understand the issue... It's hard using mc with misaligned Fx keys...

comment:3 Changed 3 years ago by kloczek

Now.... How to solve this issue ? And what would be the proper answer that I can give within the Fedora bugreport so the Fedora developers understand the issue... It's hard using mc with misaligned Fx keys...

Seems like ncurses misc/terminfo.src terminals definitions needs to be fixed.
It may more such reports and all of them should have included reporting $TERM variable value.

PS. I was responsible for switching mc in Fedora from SLang to ncurses.
I'm using quite long time mc with ncurses on Solaris. However I must confess that I never been using ctrl and shift key combinations :P

comment:4 Changed 3 years ago by zaytsev

@kloczek, since it seems that you're doing some work on mc SPEC in Fedora now, could you please also have a look at

https://bugzilla.redhat.com/show_bug.cgi?id=1383054

I've asked several times to fix this already, but no dice so far. Thanks!

comment:5 Changed 3 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from mc-core to mc-tty
  • Milestone Future Releases deleted

Closed as duplicate of #3254.

Note: See TracTickets for help on using tickets.