Ticket #3790 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

Search bug on editor

Reported by: IvanAli Owned by:
Priority: major Milestone:
Component: mc-search Version: 4.8.15
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:


I was working on a Latex file, and I tried to find occurrences of \newline in MCEdit. All I got was "Search string not found". I tried the same in the internal viewer but this time it did find the occurrences

MC and MCEdit version: 4.8.15

Change History

comment:1 Changed 7 years ago by IvanAli

  • Component changed from mc-core to mcedit

comment:2 Changed 7 years ago by zaytsev

Cannot reproduce on 4.8.19; can you upgrade and if the problem is still there, provide a sample file?

comment:3 Changed 7 years ago by andrew_b

  • Version changed from master to 4.8.15

comment:4 Changed 7 years ago by mooffie

Are you sure the search type is "Normal"? If it's "Regular expression" it'd fail (as the "\n" in "\newline" gets translated to a real newline).

(The editor and the viewer don't share the search settings, so it's possible to have "Normal" in the viewer and "Regular expression" in the editor.)

Last edited 7 years ago by mooffie (previous) (diff)

comment:5 Changed 7 years ago by IvanAli

Hi! Thanks for the help.

It seems after all I had "Regular expression" checked instead of "Normal". Now it works. I thought I had tried both last night but then again it was late and I was tired so probably I did something wrong.

comment:6 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Component changed from mcedit to mc-search
  • Milestone Future Releases deleted

Ok, closed.

Note: See TracTickets for help on using tickets.