Ticket #3777 (closed enhancement: invalid)

Opened 3 years ago

Last modified 3 years ago

Trivial typo: please amend 'Replac' to 'Replace'

Reported by: rdmo Owned by:
Priority: trivial Milestone:
Component: translations Version: master
Keywords: typo Cc: egmont
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by egmont) (diff)

https://midnight-commander.org/browser/po/en_GB.po#L1550 is:

msgid "ButtonBar|Replac"

Please amend it to:
msgid "ButtonBar|Replace"

Sorry this isn't a patch. That's somewhere further along the learning curve.

Change History

comment:1 Changed 3 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted

This is not a typo. Button bar labels are adjusted on purpose such that they fit standard size 80x24 terminals.

comment:2 Changed 3 years ago by zaytsev

Ticket #3776 has been marked as a duplicate of this ticket.

comment:3 Changed 3 years ago by egmont

  • Description modified (diff)

comment:4 Changed 3 years ago by egmont

As an improvement, we could allow multiple translations for button labels (e.g. separated by the pipe symbol) and the longest one that fits without being truncated would be chosen automatically. (Don't we already have a ticket for this??)

E.g.

msgstr "Replac|Replace"
msgstr "Ren|RenMov|RenameMove|Rename/Move|Rename or Move"
msgstr "PullDn|PullDown|Pull Down|Pull Down Menu"

etc.

It is crucial that mc is usable on 80 columns (and "Replac" is way better than "Rep~ce" as the result of automatic truncation of "Replace" to 6 characters), yet presumably many people often use it on wider terminals and why not use the available UI to show more information and/or proper spelling?

Or is this an overkill?

comment:5 Changed 3 years ago by egmont

  • Cc egmont added

comment:6 Changed 3 years ago by egmont

Even on 70 columns (5 characters per button) it would be better have "RenMv" instead of "Re~ov", "Del" instead of "De~te" etc.

comment:7 Changed 3 years ago by ossi

i implemented length variants in Qt, and it's an utter nightmare for the dynamic layout system (which is why the feature is mostly ignored). that may be a lesser concern with mc's more rigid layouting.

if you go for this, i suggest you take inspiration from Qt Linguist's handling of the strings in .po files, to avoid another non-standard extension: longest variant first, U+2762 as variant separator (in .qm files (.mo equivalent), the separator is U+9c, but that's not reliably representable in a text file, so i chose an arbitrary character which looks a bit like a separator and is very unlikely to show up in a message).

Note: See TracTickets for help on using tickets.