Ticket #3743 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

v4.8.18 crash with <Ctrl-\>

Reported by: guido Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: hotlist;key mapping Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I just built 4.8.18 to upgrade from 4.8.17; it's a regression.

In either console or Xterm, <Ctrl-\>, to activate Hotlist kills or crashes or exits mc. Hotlist from the menu functions fine.

What's wrong? My error? New feature?

Thanks for prompt attention.

Change History

comment:1 Changed 2 years ago by andrew_b

What about mc -V at least?

comment:2 Changed 2 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3697 .

comment:3 Changed 2 years ago by andrew_b

@zaytsev I think we should clarify "duplicate" and "invalid" resolutions.
IMO:
The ticket N can be closed as duplicate of ticket M if M is open.
If ticket M is already closed (i. e. bug is fixed), the ticket N should be closed as invalid.

comment:4 Changed 2 years ago by zaytsev-work

Hi Andrew,

In my opinion it makes sense to mark tickets regarding exactly the same bug as duplicate irrespectively of whether the bug has already been fixed, or is still open. The additional benefit in this as I see it is that no further comments are needed, and tickets are linked automatically. All the projects I've worked with are doing it this way.

Invalid status for me reflects that the problem either 1) doesn't have to do with mc, but rather some external library / terminal / etc. or 2) is user error, as in misunderstanding of the documentation, wrong configuration, etc. It doesn't have to do with whether the bug has already been reported and / or fixed.

I think that the system you are proposing is more complicated and I don't see the benefit. However, my opinion is not very strong. If it is of existential importance for you, I will give in.

--Yury.

comment:5 Changed 2 years ago by zaytsev-work

I think I can use this opportunity to clarify the usage of milestones ;-) Maybe you could explain me the benefit of removing the milestones from duplicate / invalid tickets, if the milestone is NOT "Future releases"?

I think it's not too bad to have invalid / duplicate tickets resolved at a particular milestone, because I often spend a lot of time trying to investigate before finding another report, or realising that the report is invalid. So, I think it's good to register this time at a particular milestone.

For "Future releases", I understand that you want to use it as a filter for stuff to be done, and invalid / duplicate tickets shouldn't be there. I agree with this.

Note: See TracTickets for help on using tickets.