Ticket #3707 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

ctrl+o press bug in csh, Freebsd 10

Reported by: krs_vital Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

uname-r
10.2-RELEASE-p9

installed via the package installer pkg.

The problem is when you press ctrl+o in csh.
Disappears screen, it is inconvenient to debug a program as constantly having to scroll up to view its output on the screen. This problem appears in almost all new releases. I wrote earlier that you fixed, but then again it appears. It is possible to solve this problem so that all new releases in csh everything works as in bash?

Change History

comment:1 Changed 5 years ago by zaytsev

I don't understand what are you talking about. Are you saying that subshell is not detected? In 4.8.17+ both tcsh and tcsh aliased as csh should work. Alternatively, see if #3692 helps...

comment:2 Changed 5 years ago by krs_vital

no, I wrote that subshell is opened in a blank window and the information that was there before (the output of a program) is not visible, you have to scroll up and every time after pressing ctrl+o increases the number of blank windows, and to see the output program to have to constantly climb up inside subshell

comment:3 Changed 5 years ago by woodsb02

I believe this is a duplicate of ticket:3659

comment:4 Changed 5 years ago by krs_vital

yes, its very similar, but the problem is in new versions, can you consider this bug in future versions and fix this in the next release?

P.S.:
freebsd install mc comes from packages are already compiled

comment:5 Changed 5 years ago by zaytsev

So, the patch by Ben doesn't fix the issue anymore?

comment:6 Changed 5 years ago by krs_vital

i cant to patch because package doesnt have source codes, its binary

installation string to install mc in freebsd looks like

pkg install mc

comment:7 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2633.

Note: See TracTickets for help on using tickets.