Changes between Initial Version and Version 1 of Ticket #3684, comment 21


Ignore:
Timestamp:
09/24/16 10:52:19 (5 years ago)
Author:
alllexx88
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #3684, comment 21

    initial v1  
    55 
    66I think I do have an impression of what your patch does, and I think from user's point of view it's good as it is, as long as it's documented thoroughly, and I have an impression of you being good at that. However, some things look a bit misleading from code readability point of view: 
    7 1) `mc_config_get_home_dir()` function name implies that it's return actually depends on on mc config, which is not true (and I agree, in master it is mostly used in the code as user home, except for configs) and causes confusion. I does make some sense to have a function for that, instead of just using `getenv(HOME)` just in case the env value gets messed up, but maybe it's sensible to change the name to something like `mc_get_user_home_dir()` -- or whichever you see fit? What do you think? 
     71) `mc_config_get_home_dir()` function name implies that it's return actually depends on on mc config, which is not true (and I agree, in master it is mostly used in the code as user home, except for configs) and causes confusion. I does make some sense to have a function for that, instead of just using `getenv(HOME)` just in case the env value gets messed up, but maybe it's sensible to change the name to something like `mc_config_get_user_home_dir()` -- or whichever you see fit? What do you think? 
    882) (this is there before your patch actually) Some comments regarding config paths are misleading, like in `src/subshell/common.c`: 
    99