Ticket #3649 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 5 years ago

Set local file copy stat data

Reported by: Nicolas Rybkin Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When MC copies a file into some EXTFS it uses a local copy of source file and gives a path to this copy to EXTFS scripit. But it doesn't set stat info of this local file, so EXTFS script has no chance to get stat info of true source.
I've fixed this problem, now MC performs chown(), chmod() and utime() on local copy. Struct definitions from src/vfs/extfs/extfs.c were moved to extfs.h, src/filemanager/file.c now includes extfs.h.

Change History

comment:1 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3650.

Note: See TracTickets for help on using tickets.