Ticket #3624 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

slow performance due to small buffer used in mc_read()

Reported by: ioan Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

hi

mc_read() in file.c uses 8K buffer while copying files. i've maked some measurements of copying speed under two machines:
1) mac os, 10gbit network. copying to NAS (which have shared SSD with >1Gbyte/s throughput) using NFS - 150mb/s
2) ubuntu, local copying between two virtual disks - 350mb/s.

now i modify buffer 'buf', which used by mc_read()/wc_write() as temporary buffer for copying. i increased it's size from 8kbytes to 2mbytes. how we have following situation:
1) under mac os, speed increased from 150mb/s to 385mb/s
2) under ubuntu, speed increased from 350mb/s to 1900mb/s.

i've tested various buf sizes and 2mbytes is optimal in my situation (i've tested mostly using NFS over 10gbit network).

Change History

comment:1 Changed 3 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2193.

Note: See TracTickets for help on using tickets.