Ticket #3619 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

can't print text when i press ctrl+o in gui mode via ssh connection.

Reported by: krs_vital Owned by:
Priority: major Milestone: 4.8.17
Component: mc-core Version: 4.8.16
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

can't print text when i press ctrl+o in gui mode via ssh connection.

Change History

comment:1 Changed 4 years ago by krs_vital

  • Summary changed from mc-4.8.18 to mc-4.8.16

comment:2 Changed 4 years ago by andrew_b

  • Version changed from master to 4.8.16
  • Summary changed from mc-4.8.16 to can't print text when i press ctrl+o in gui mode via ssh connection.

comment:3 Changed 4 years ago by zaytsev-work

Shall we close it as invalid? This report is neither understandable, nor reproducible.

What is "gui mode"? What means "via ssh connection"? Which distribution / terminal emulator is installed on the host you connect from? Which distribution / shell is installed on the host you connect to?

Obviously not even one second has been taken to think of what information might be needed in order to fix this problem if it's a genuine issue with mc.

comment:4 Changed 4 years ago by krs_vital

возможно я не так объяснил, так как мой английский оставляет желать лучшего...
на новой версии, которую я установил из пакетов FreeBSD 10.2, при включенном графическом интерфейсе при нажатии ctrl+o он пропадал и появлялась командная строка, где можно было работать, в последней версии нельзя работать с командной строкой, причём эта проблема появляется только когда работаешь с сервером по ssh, если работать локально, то такой проблемы нет!

эта проблема у вас проскакивает от версии к версии

comment:5 Changed 4 years ago by zaytsev-work

Does one need anything special to reproduce it, or it's just

1) install vanilla FreeBSD 10.2
2) ssh into the host
3) observe that subshell is not working on Ctrl+O

What's your user shell? Does it work with /usr/bin/bash?

comment:6 follow-up: ↓ 9 Changed 4 years ago by krs_vital

my user shell is /bin/csh - standart for freeBSD

i change it to /usr/local/bin/bash and subshell works well:)

but bash is not default for freebsd

can you fix this problem for csh?

previous version of mc worked with csh

Last edited 4 years ago by krs_vital (previous) (diff)

comment:7 Changed 4 years ago by zaytsev-work

Okay, there is one more report from another FreeBSD user that csh is now broken, after integrating the "improvements" from #2742. I'll close this one as a duplicate, hopefully someone who cares about csh can help us with a patch, that hopefully doesn't break all the rest (as usual).

comment:8 Changed 4 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone changed from Future Releases to 4.8.17

Closed as duplicate of #2742.

comment:9 in reply to: ↑ 6 Changed 4 years ago by zaytsev

Replying to krs_vital:

can you fix this problem for csh?

I've attached a temporary fix to #2742 (0001-Ticket-2742-detect-csh-as-tcsh-by-name.patch), hopefully will be fixed in the next release.

Note: See TracTickets for help on using tickets.