Ticket #3588 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Cannot set mini-format for "brief" listing type

Reported by: mooffie Owned by: andrew_b
Priority: trivial Milestone: 4.8.16
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

Steps to reproduce:

  1. Go to the "Listing mode" dialog.
  2. Select "Brief file list".
  3. Tick the "User mini status" checkbox.
  4. Modify the mini status format field (e.g., append " inode").
  5. Hit ENTER. Bug: the format you modified doesn't take effect.

The patch fixes this.

(Note: if you close the dialog by hitting ENTER when the focus is at the radios widget, the modified mini-format won't take effect even with this patch. This is because of a non-related bug fixed in ticket:3587 (search there for "it overwrites the mini status format the user has typed").)

Attachments

3588-cannot-set-mini-format-for-brief-listing-type.patch (803 bytes) - added by mooffie 4 years ago.

Change History

comment:1 Changed 4 years ago by zaytsev-work

  • Milestone changed from Future Releases to 4.8.16

comment:2 Changed 4 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Votes for changeset set to andrew_b
  • Branch state changed from no branch to on review

comment:3 Changed 4 years ago by andrew_b

  • Branch state changed from on review to approved

comment:4 Changed 4 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:5 Changed 4 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.