Ticket #3576 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

[mcview] No "not found" message if searching for text from the beginning of the file

Reported by: lastique Owned by:
Priority: major Milestone:
Component: mcview Version: 4.8.13
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

If, when searching for a string in a text file open for viewing, the string is not found in the file, mcview does not display any messages at the end of search. This only happens if the file is open for view at the very beginning.

Steps to reproduce:

  1. Open a relatively large text file for viewing. (F3)
  2. Make sure you're looking at the beginning of the file. (Home)
  3. Search for a string that is not in the file. (F7, type the string, Enter).

Actual results:

After the search is complete (judging by the CPU load), no messages are displayed. It's hard to tell what the result of the operation was.

Expected results:

mcview should display the message that the string was not found. It does so when the search is performed from the middle of the file.

Kubuntu 15.10, x86_64.

$ LC_MESSAGES=C mc -V
GNU Midnight Commander 4.8.13
Built with GLib 2.43.1
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

$ LC_MESSAGES=C mc -F
Root directory: /home/lastique

[System data]

Config directory: /etc/mc/
Data directory: /usr/share/mc/
File extension handlers: /usr/lib/mc/ext.d/
VFS plugins and scripts: /usr/lib/mc/

extfs.d: /usr/lib/mc/extfs.d/
fish: /usr/lib/mc/fish/

[User data]

Config directory: /home/lastique/.config/mc/
Data directory: /home/lastique/.local/share/mc/

skins: /home/lastique/.local/share/mc/skins/
extfs.d: /home/lastique/.local/share/mc/extfs.d/
fish: /home/lastique/.local/share/mc/fish/
mcedit macros: /home/lastique/.local/share/mc/mc.macros
mcedit external macros: /home/lastique/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /home/lastique/.cache/mc/

$ mc --configure-options

'--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--libdir=${prefix}/lib/x86_64-linux-gnu' '--libexecdir=${prefix}/lib/x86_64-linux-gnu' '--disable-maintainer-mode' '--disable-dependency-tracking' 'AWK=awk' 'X11_WWW=x-www-browser' '--libexecdir=/usr/lib' '--with-x' '--with-screen=slang' '--disable-rpath' '--disable-static' '--disable-silent-rules' '--enable-aspell' '--enable-vfs-sftp' '--enable-vfs-undelfs' '--enable-tests' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-Bsymbolic-functions -fPIE -pie -Wl,-z,relro -Wl,-z,now -Wl,--as-needed' 'CPPFLAGS=-D_FORTIFY_SOURCE=2'

Change History

comment:1 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3543.

Note: See TracTickets for help on using tickets.