Ticket #3555 (closed task: fixed)

Opened 4 years ago

Last modified 4 years ago

Minor code cleanups

Reported by: mooffie Owned by:
Priority: minor Milestone: 4.8.16
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset: committed-master

Description


Attachments

0001-panel.h-define-typedef-list_type_t.patch (1.3 KB) - added by mooffie 4 years ago.
0002-panel.h-remove-unused-variable-declaration.patch (633 bytes) - added by mooffie 4 years ago.
0003-button_get_text-shouldn-t-return-const.patch (1.3 KB) - added by mooffie 4 years ago.

Change History

Changed 4 years ago by mooffie

Changed 4 years ago by mooffie

Changed 4 years ago by mooffie

comment:1 follow-up: ↓ 2 Changed 4 years ago by andrew_b

  • Blocked By 3547 added
  • Milestone changed from Future Releases to 4.8.16

No reason for special ticket. Use #3547 instead.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 4 years ago by mooffie

Replying to andrew_b:

No reason for special ticket. Use #3547 instead.

Ah, OK, sorry. I thought #3547 was intended for patches to be committed right before 4.8.16 goes out.

comment:3 in reply to: ↑ 2 Changed 4 years ago by zaytsev-work

Replying to mooffie:

Ah, OK, sorry. I thought #3547 was intended for patches to be committed right before 4.8.16 goes out.

The idea behind these cleanup tickets is get rid of _some_ bureaucracy for trivial changes: instead of creating a ticket for each and every whitespace fix, having people to vote on it, making a feature branch and merging it, etc. one can commit this kind of stuff directly into the cleanup branch, get it reviewed before release in one batch, or rebase & merge from time to time during the development cycle...

comment:4 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset set to committed-master
  • Resolution set to fixed

0001-panel.h-define-typedef-list_type_t.patch​: [162f8a9fa7d5d5da694f8029a80dfa8b71daad09]
0002-panel.h-remove-unused-variable-declaration.patch​: [2627da4b735a8f53728b9f83ff76106b553dc78e]
0003-button_get_text-shouldn-t-return-const.patch​: [5fad7508c535cc8e92af03de9b37f4b52eaa6979]

comment:5 Changed 4 years ago by andrew_b

  • Blocked By 3547 removed
Note: See TracTickets for help on using tickets.