Ticket #3543 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

search: Non-match not reported for parsed files from the beginning

Reported by: egmont Owned by: andrew_b
Priority: major Milestone: 4.8.16
Component: mcview Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

Open a file in mcview's "Parsed" mode (you see "8Raw" at the bottom). E.g. F3 on a tarball (like mc-4.8.14.tar.xz, or whatever).

Press F7 and search for a string that doesn't occur in the file, such as "asdf".

Expected: A new error dialog informing you about the string not being found.

Actual: Nothing. The search dialog disappears and you're back in the file viewer.

Seems to occur only if you're in Parsed mode, and only if you start the search from the beginning of the file.

Broke somewhere between 4.8.12 and 4.8.13.

Change History

comment:1 Changed 4 years ago by egmont

dc03e9e28d9c58df9c37e6911e54944fd5a5bdca is the first bad commit
commit dc03e9e28d9c58df9c37e6911e54944fd5a5bdca
Author: Andrew Borodin <aborodin@…>
Date: Thu Mar 14 16:21:41 2013 +0400

mcviewer: apply status message for search process.

Signed-off-by: Andrew Borodin <aborodin@…>

comment:2 Changed 4 years ago by egmont

@andrew_b:

Could you please take a look at this? You're much more familiar with this part of the code than I am.

I've got plenty of things to do nowadays, I'm not planning to work on this bug.

search_start's off-by-one semantics (#3280) might be relevant, not sure.

comment:3 Changed 4 years ago by zaytsev

I just wanted to post:

D'oh, sounds like a suicide to look into it without a bisection :-/

and I've a Trac editing conflict. Guess what? You've just bisected it! Well done :-)

comment:4 Changed 4 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.16

Branch: 3534_mcview_not_found
Initial changeset:7233ed9a0949cee15d7f55fc37431fde7e11b89d

comment:5 Changed 4 years ago by egmont

@andrew_b:

Sorry for not responding earlier. I haven't looked at the code, just applied the patch now and it seems to work. I'll keep on using it.

Note: the ticket number in the git branch name is incorrect.

Last edited 4 years ago by egmont (previous) (diff)

comment:6 Changed 4 years ago by andrew_b

Ticket #3576 has been marked as a duplicate of this ticket.

comment:7 follow-up: ↓ 8 Changed 4 years ago by andrew_b

Branch was renamed: 3543_mcview_not_found.
Initial changeset:7233ed9a0949cee15d7f55fc37431fde7e11b89d

I'm still waiting for any vote.

comment:8 in reply to: ↑ 7 Changed 4 years ago by andrew_b

Replying to andrew_b:

I'm still waiting for any vote.

"Tom!"
No answer.
"Tom!"
No answer.

Yet another week of silence.
O'key.

comment:9 Changed 4 years ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:10 Changed 4 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

Merged to master: [72e20fce47b6cd123426ac246702d58604d8e300].

git log --pretty=oneline 1cf18ab..72e20fc

comment:11 Changed 4 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.