Ticket #3528 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

MC crashes when selecting too many files and adding their name to a bash command with CTRL-X C

Reported by: albator Owned by:
Priority: blocker Milestone:
Component: mc-core Version: 4.8.11
Keywords: crash, select, files,bash Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

1) I select 2642 files in a folder with pressing *
2) I add the names of all these files to a bash command (cat file1 file2... >>all.txt) with pressing CTRL-X C
3) MC crashes : Erreur de segmentation

Change History

comment:1 Changed 4 years ago by albator

  • Summary changed from MC crash when selecting too many files and adding their name to a bash command with CTRL-X C to MC crashes when selecting too many files and adding their name to a bash command with CTRL-X C

comment:2 Changed 4 years ago by albator

NU Midnight Commander 4.8.11
Construit avec GLib 2.39.1
Using the S-Lang library with terminfo database
Avec l'éditeur intégré
With subshell support as default
Avec le support des opérations en tâche de fond
Avec support de la souris pour xterm et la console Linux
Avec le support des événements X11
Avec le support de l'internationalisation
Avec le support de plusieurs codepages
Systèmes des fichiers virtuels: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Types de données : char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

comment:3 Changed 4 years ago by albator

  • Version changed from master to 4.8.11
  • Milestone changed from Future Releases to 4.8

comment:4 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone 4.8 deleted
  1. You use the old version of mc. Please try recent version as you've been asked.
  2. ctrl-x c is shortcut for Chmod command. Probably, you mean ctrl-x t.
  3. I cannot reproduce this crash in recent master snapshot.

I close this thicket as invalid because of 1) and 3).

Last edited 4 years ago by andrew_b (previous) (diff)
Note: See TracTickets for help on using tickets.