Ticket #3507 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Panelize view loses search results after opening 2 files.

Reported by: majster.splinter Owned by:
Priority: major Milestone: 4.8.15
Component: mc-core Version: 4.8.13
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Panelize view loses search results after opening 2 of the found files.

MC version:

GNU Midnight Commander 4.8.13
Built with GLib 2.41.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Steps to reproduce:

  1. open mc
  2. search for some files with command M-?
  3. panelize results
  4. open some file - panelized files are ok
  5. open another file - panelized files are lost

Expected results:

Panelized files should be visible until panelized view is canceled.

Change History

comment:1 follow-up: ↓ 3 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Keywords panelize removed
  • Version 4.8.13 deleted
  • Resolution set to duplicate

Closed as duplicate of #3498.
What about use search before create the ticket?

comment:2 Changed 4 years ago by andrew_b

  • Version set to 4.8.13
  • Milestone Future Releases deleted

comment:3 in reply to: ↑ 1 ; follow-up: ↓ 4 Changed 4 years ago by majster.splinter

Replying to andrew_b:

Closed as duplicate of #3498.
What about use search before create the ticket?

I've seen that ticket and didn't have that bug when editing with F4. Only when files opened with external editor.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 4 years ago by andrew_b

Replying to majster.splinter:

Replying to andrew_b:

Closed as duplicate of #3498.
What about use search before create the ticket?

I've seen that ticket and didn't have that bug when editing with F4. Only when files opened with external editor.

I didn't see the 'external editor' words in this ticket.
I hope, the root of bug is fixed in #3489.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 4 years ago by majster.splinter

Replying to andrew_b:

Replying to majster.splinter:

Replying to andrew_b:

Closed as duplicate of #3498.
What about use search before create the ticket?

I've seen that ticket and didn't have that bug when editing with F4. Only when files opened with external editor.

I didn't see the 'external editor' words in this ticket.
I hope, the root of bug is fixed in #3489.

Yeah, I didn't mention it in the ticket. My bad.
Could you test it? Do you have Branch: 3489_reload_panelize compiled?

comment:6 in reply to: ↑ 5 Changed 4 years ago by andrew_b

Replying to majster.splinter:

Could you test it?

I hope, I can do it at weekend.

Do you have Branch: 3489_reload_panelize compiled?

Unfortunately, no.

comment:7 Changed 4 years ago by andrew_b

  • Milestone set to 4.8.15

Fixed as #3489.

Note: See TracTickets for help on using tickets.