Ticket #350 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

mc compare directories (thorough) thinks empty files are different

Reported by: snizovtsev Owned by: slavazanko
Priority: trivial Milestone: 4.7
Component: mc-core Version: 4.6.2
Keywords: commited-master Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

https://bugs.launchpad.net/ubuntu/+source/mc/+bug/181034
The bug was caused by mmap behaviour when length = 0. Here is quote from man(3) mmap:

SUSv3 specifies that mmap() should fail if length is 0. However, in kernels before 2.6.12, mmap() succeeded in this case: no mapping was created
and the call returned addr. Since kernel 2.6.12, mmap() fails with the error EINVAL for this case.

Attachments

fix_compare_on_empty_file.diff (397 bytes) - added by snizovtsev 10 years ago.

Change History

Changed 10 years ago by snizovtsev

comment:1 Changed 10 years ago by snizovtsev

  • Priority changed from major to trivial
  • Milestone changed from 4.7 to 4.6.2.1

comment:2 Changed 10 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted
  • Milestone changed from 4.6.2.1 to 4.7

comment:3 Changed 10 years ago by slavazanko

  • Keywords review vote-slavazanko added

branch 350_compare_empty_files created(parent: master)

See changeset:8c441fdd1205448ef763814366691f65fb10302d

My vote here.

comment:4 Changed 10 years ago by styx

  • Keywords vote-styx approved added; review removed

comment:5 Changed 10 years ago by styx

  • Status changed from accepted to testing
  • Resolution set to fixed

comment:6 Changed 10 years ago by styx

  • Keywords commited-master added; vote-slavazanko vote-styx approved removed
  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.