Ticket #349 (closed defect: duplicate)

Opened 10 years ago

Last modified 8 years ago

git master: vfs: stale cache in /tmp/ after container modification

Reported by: slyfox Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc: ip1024@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Steps to reproduce:

  1. create archive/iso/patch in /tmp/foo.diff
  2. enter there (<ENTER> in panel viewer) and out
  3. modify archive/iso/patch
  4. enter there again: we get out-of-date contents

To prevent this problem in this simple case we can associate container size and last modification time with vfs cached file.
I think they can be encoded directly into cached name in /tmp/mc-$USER/.

Change History

comment:1 Changed 10 years ago by igorp1024

  • Cc ip1024@… added
  • severity set to no branch

comment:2 Changed 10 years ago by slavazanko

  • Milestone changed from 4.7 to VFS Standardization

comment:3 Changed 9 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #62.

comment:4 Changed 9 years ago by zaytsev

  • Version changed from 4.6.2 to master
  • Milestone 4.8 deleted

comment:5 Changed 8 years ago by andrew_b

  • Component changed from mc-core to mc-vfs
  • Branch state set to no branch
Note: See TracTickets for help on using tickets.