Ticket #3441 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Segmentation fault on startup

Reported by: asy Owned by: andrew_b
Priority: critical Milestone: 4.8.15
Component: mc-core Version: 4.8.14
Keywords: Cc:
Blocked By: Blocking:
Branch state: approved Votes for changeset: committed-master

Description (last modified by andrew_b) (diff)

Version: 4.8.14-alt0.M60P.2
System: Alt Linux p6 brunch, x86_64
Possible it is a hardware specific error: mc works fine on some other systems with equivalent software installation.

strace output with debuginfo:

open("/usr/share/mc/hints/mc.hint.C", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/mc/hints/mc.hint.C", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/mc/hints/mc.hint", O_RDONLY) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=3023, ...}) = 0
read(4, "Hint: Use C-x t to copy tagged f"..., 3023) = 3023
close(4)                                = 0
write(1, "\33[41;1H\33(B\33[m\33(B\33[39m\33[49mHint: "..., 103) = 103
stat("/proc/self/mountinfo", {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
open("/proc/self/mountinfo", O_RDONLY)  = 4
fstat(4, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f14d0681000
read(4, "19 1 8:3 / / rw,relatime - ext3 "..., 1024) = 1024
read(4, "dev/sda8 rw,errors=continue,barr"..., 1024) = 51
read(4, "", 1024)                       = 0
close(4)                                = 0
munmap(0x7f14d0681000, 4096)            = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0} ---
+++ killed by SIGSEGV +++
Segmentation fault

Attachments

core-mc-4.8.14-alt0.M60P.2 (1.8 MB) - added by asy 7 years ago.
core dump, x86_64 system
0001-Ticket-3441-fix-Linux-kernel-specific-segfault-on-st.patch (10.1 KB) - added by andrew_b 7 years ago.

Change History

comment:1 Changed 7 years ago by asy

  • Version changed from master to 4.8.14

Changed 7 years ago by asy

core dump, x86_64 system

comment:2 Changed 7 years ago by asy

This is a kernel specific. MC's code for /proc/self/mountinfo does not works with some kernels of p6.
kernel-image-el-smp-2.6.32-alt31 - fail
kernel-image-ovz-el-2.6.32-alt88.M60P.1 - works

So, mc should be build without /proc/self/mountinfo support. Not a bug for mc.

comment:3 Changed 7 years ago by andrew_b

  • Description modified (diff)

comment:4 Changed 7 years ago by andrew_b

Please try the attached 0001-Ticket-3441-fix-Linux-kernel-specific-segfault-on-st.patch​.

comment:5 Changed 7 years ago by asy

mc with patch starts successfully with 2.6.32-el-smp-alt24(i586), thanks.

Last edited 7 years ago by asy (previous) (diff)

comment:6 Changed 7 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Branch state changed from no branch to approved
  • Milestone changed from Future Releases to 4.8.15

comment:7 Changed 7 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset set to committed-master
  • Resolution set to fixed

comment:8 Changed 7 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.