Ticket #342 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

git master: editor: fancy highlighted tabs and spaces do not mark by F3 block marking

Reported by: slyfox Owned by: angel_il
Priority: major Milestone: 4.7
Component: mc-core Version:
Keywords: commited-master Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Steps to reproduce

  1. open text file
  2. place some traling tabs and scaces
  3. try to mark it via F3

Nothing happens (they are marked, but marking is unvisible)

Change History

comment:1 Changed 10 years ago by angel_il

  • Status changed from new to accepted
  • Owner set to angel_il

comment:2 Changed 10 years ago by angel_il

  • Status changed from accepted to assigned
  • Keywords review added

branch: 342_tabs_spaces_mark
Changeset: 7fbff4fa86401db3d4ff596d32f187e3d03640e4

comment:3 Changed 10 years ago by slavazanko

  • Keywords vote-slavazanko added

Well, nice fix. Works correctly, tabs and spaces selected.

Vote here.

comment:4 Changed 10 years ago by slyfox

  • Keywords vote-slyfox approved added

Looks good. Thanks!

comment:5 Changed 10 years ago by angel_il

  • Status changed from assigned to testing
  • Keywords commited-master added; review vote-slavazanko vote-slyfox approved removed
  • Resolution set to fixed

comment:6 Changed 10 years ago by styx

  • Status changed from testing to closed

comment:7 Changed 10 years ago by ossi

yeah. thanks *so* much for "fixing" this. never mind that it was intentionally that way.

you broke two things at once:

  • due to the uniform coloring of the selection, the visible whitespace is in no way subtle any more. consequently selected text with lots of whitespace (say, properly tabbed out source code) becomes something between plain ugly and totally unreadable.
  • you removed the workaround to make text usefully selectable for mouse-based copy&paste in x, as there is now no way to get rid of the whitespace vizualizers. this was supposed to be quickly toggleable at some point, but it still doesn't seem to be.

and the obvious question is: why on earth do you want visible whitespace in selections? trailing whitespace is visualized by the selection itself, and i see no use case for the distinction between tabs and spaces in this context.

Note: See TracTickets for help on using tickets.