Ticket #3395 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

RenMov to same fs performs a slow directory scanning

Reported by: egmont Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Press F6 on a giant directory tree, and rename/move to another name/location within the same physical file system.

Actual behavior: A "Directory scanning" dialog pops up and scans its contents, which might take many seconds if the tree is large. You could press Skip in which case this step is skipped and the directory is moved, although it's not obvious from the name that it's not the moving that will be skipped.

Expected behavior: Just execute that one single rename() call and it's done. No dialog should be popped up and no expensive task should be performed for an O(1) operation.

Change History

comment:1 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #3149.

comment:2 Changed 5 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.