Ticket #3377 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

mcedit cannot highlight echo "$(echo "$(echo)")" normally

Reported by: safinaskar Owned by:
Priority: major Milestone:
Component: mcedit Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

mcedit cannot highlighting the following shell code normally:

echo "$(echo "$(echo)")"
echo

The last "echo" should be the same color as the first one, but it has quoted text color.

You may say such code is too complicated and will not appear in real source. No. This code is simplified form of the following absolutely real code:

if ! RESPONSE="$(wget -O - "https://api.vk.com/method/account.getAppPermissions?access_token=$(cat /tmp/.vk-token)" 2> /dev/null)"; then

This code is part of my vk.com audio player. And I have to add # " to the end of line to get normal highlighting, and, of course, I don't like this hack.

Version: latest git master b7b78319f0c8797269089acf7eb1eb08b48a96e8.

9 2014-12-12 04:00:23 ~/tmp/mc# LC_MESSAGES=C src/mc -V
GNU Midnight Commander 4.8.13-47-gb7b7831
Built with GLib 2.32.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;
9 2014-12-12 04:01:15 ~/tmp/mc# LC_MESSAGES=C src/mc -F
Root directory: /root

[System data]

Config directory: /tmp/null/etc/mc/
Data directory: /tmp/null/share/mc/
File extension handlers: /tmp/null/libexec/mc/ext.d/
VFS plugins and scripts: /tmp/null/libexec/mc/

extfs.d: /tmp/null/libexec/mc/extfs.d/
fish: /tmp/null/libexec/mc/fish/

[User data]

Config directory: /root/.config/mc/
Data directory: /root/.local/share/mc/

skins: /root/.local/share/mc/skins/
extfs.d: /root/.local/share/mc/extfs.d/
fish: /root/.local/share/mc/fish/
mcedit macros: /root/.local/share/mc/mc.macros
mcedit external macros: /root/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /root/.cache/mc/

9 2014-12-12 04:01:42 ~/tmp/mc# src/mc --configure-options

'--prefix=/tmp/null'

Change History

comment:1 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2142.

Note: See TracTickets for help on using tickets.