Ticket #3350 (closed defect: duplicate)

Opened 5 years ago

Last modified 3 years ago

"Select group" selects file it shouldn't

Reported by: a_b Owned by:
Priority: minor Milestone:
Component: mc-search Version: 4.8.13
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

GNU Midnight Commander 4.8.13
Built with GLib 2.42.0
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, smbfs
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

OS: openSUSE 13.2

To reproduce the bug:

  1. create a file named "a,1" (without the quotes) in the current directory
  2. press the + button to select a group of files
  3. enter "a,jklmn 56789" (without the quotes) as selection string

MC selects the file named "a,1".

Change History

comment:1 Changed 5 years ago by boris

  • Component changed from mc-core to mc-search

This is a special case of #2309. "a,jklmn 56789" is translated as two alternatives: "^a" and "jklmn 56789$", the first one matches.

comment:2 Changed 4 years ago by andrew_b

  • Blocked By 2309 added

comment:3 Changed 4 years ago by slavazanko

  • Blocked By 2309 removed

(In #2309) Merged to master:

git log --pretty=oneline f4faf60..6ca737d

comment:4 Changed 3 years ago by mooffie

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #2577.
This got fixed by #2309.

comment:5 Changed 3 years ago by andrew_b

  • Milestone Future Releases deleted

comment:6 Changed 3 years ago by zaytsev

Thank you very much for helping to triage this!

Note: See TracTickets for help on using tickets.