Ticket #3249 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Midnight Commander cannot connect via SSH after the network connection got broken and then up again

Reported by: csbubbles Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.8.12
Keywords: ssh shell link connection Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Repro:

  1. Open Midnight Commander
  2. Connect to a remote server via SSH (menu: "Left" / "Shell link...")
  3. Wait till the connection gets broken (to force it, simply disconnect from the network in the system)
  4. Try to navigate through the directories on the remote machine (which is unavailable now), Midnight Commander will start navigating on the local machine
  5. Enable network again if it was disabled at the step 3
  6. Try to connect to a remote server via SSH again (menu: "Left" / "Shell link...")

Result:

Midnight Commander shows the error "Can't open ssh://... directory". And the only way to connect to a remote machine is to restart Midnight Commander (after the relaunch, you can connect to a remote machine over SSH again).

Expected result:

Midnight Commander connects to a server after the network is up again with no need to restart it.

LC_MESSAGES=C mc -V

GNU Midnight Commander 4.8.12
Built with GLib 2.40.0
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

LC_MESSAGES=C mc -F

Root directory: /Users/csbubbles

[System data]

Config directory: /opt/local/etc/mc/
Data directory: /opt/local/share/mc/
File extension handlers: /opt/local/libexec/mc/ext.d/
VFS plugins and scripts: /opt/local/libexec/mc/

extfs.d: /opt/local/libexec/mc/extfs.d/
fish: /opt/local/libexec/mc/fish/

[User data]

Config directory: /Users/csbubbles/.config/mc/
Data directory: /Users/csbubbles/.local/share/mc/

skins: /Users/csbubbles/.local/share/mc/skins/
extfs.d: /Users/csbubbles/.local/share/mc/extfs.d/
fish: /Users/csbubbles/.local/share/mc/fish/
mcedit macros: /Users/csbubbles/.local/share/mc/mc.macros
mcedit external macros: /Users/csbubbles/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /Users/csbubbles/.cache/mc/

mc --configure-options

'--prefix=/opt/local' '--without-x' '--with-screen=slang' '--with-slang-includes=/opt/local' '--with-slang-libs=/opt/local' 'CC=/usr/bin/clang' 'CFLAGS=-pipe -Os -arch x86_64' 'LDFLAGS=-L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64' 'CPPFLAGS=-I/opt/local/include'

Change History

comment:1 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2256.

Note: See TracTickets for help on using tickets.