Ticket #3236 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

mc gets hung/frozen/stalled while copying, moving or deleting big amount of files or directrories

Reported by: nrbrtx Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.11
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I use MC for copying big amount of files and directories for years without problems.
I prefer MC for its lightweight and fast operation.

But with recent versions I have faced a problem. I do not know in which version the problem appeared first. I have this problem at least in Ubuntu 12.04.4 (mc 4.8.1-2ubuntu1) and Gentoo (mc 4.8.11).

Steps to reproduce:

  1. Get a large amount of files (I checked out libreoffice git repository, about 276000 files)
  2. Open MC and try to Copy (F5) or Move (F6) files from left panel to right panel
  3. Then Copying or Moving starts, the Copy or Move dialog with progress appears, some files are copied or moved, but in some moment of time the dialog stops updating and I call this hung/frozen/stalled

Expected result:
Files and directories are copied or moved from one panel to the other without problem with showing progress.

Actual result:
MC is hung/frozen/stalled while Copying or Moving files and directories.

Note: the result is the same for any type of storage - USB flash, SATA HDD, SATA SSD.

Version info (4.8.11 on Gentoo).
LC_MESSAGES=C mc -V
GNU Midnight Commander 4.8.11
Built with GLib 2.38.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

LC_MESSAGES=C mc -F
Root directory: /home/norbert

[System data]

Config directory: /etc/mc/
Data directory: /usr/share/mc/
File extension handlers: /usr/libexec/mc/ext.d/
VFS plugins and scripts: /usr/libexec/mc/

extfs.d: /usr/libexec/mc/extfs.d/
fish: /usr/libexec/mc/fish/

[User data]

Config directory: /home/norbert/.config/mc/
Data directory: /home/norbert/.local/share/mc/

skins: /home/norbert/.local/share/mc/skins/
extfs.d: /home/norbert/.local/share/mc/extfs.d/
fish: /home/norbert/.local/share/mc/fish/
mcedit macros: /home/norbert/.local/share/mc/mc.macros
mcedit external macros: /home/norbert/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /home/norbert/.cache/mc/

mc --configure-options

'--prefix=/usr' '--build=x86_64-pc-linux-gnu' '--host=x86_64-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--libdir=/usr/lib64' '--disable-silent-rules' '--disable-dependency-tracking' '--enable-nls' '--enable-vfs' '--enable-vfs-undelfs' '--enable-charset' '--with-x' '--disable-vfs-smb' '--disable-vfs-sftp' '--enable-aspell' '--with-gpm-mouse' '--with-screen=slang' '--with-internal-edit' '--disable-mclib' '--disable-tests' '--with-homedir=XDG' 'build_alias=x86_64-pc-linux-gnu' 'host_alias=x86_64-pc-linux-gnu' 'CFLAGS=-march=corei7 -O2 -pipe' 'LDFLAGS=-Wl,-O1 -Wl,--as-needed' 'PKG_CONFIG_PATH=/usr/lib64/pkgconfig'

Attachments

ini (3.0 KB) - added by nrbrtx 5 years ago.
My MC ini
mc-copy.png (350.9 KB) - added by nrbrtx 5 years ago.
mc screenshot during Copy (looks as copy is paused)

Change History

Changed 5 years ago by nrbrtx

My MC ini

comment:1 Changed 5 years ago by nrbrtx

  • Summary changed from mc gets hung/frozen/stalled while copying or moving big amount of files or directrories to mc gets hung/frozen/stalled while copying, moving or deleting big amount of files or directrories

comment:2 Changed 5 years ago by nrbrtx

MC gets hung/frozen/stalled while deleting big amount of files and directories too.

comment:3 Changed 5 years ago by andrew_b

I'm unable to reproduce this bug on recent master snapshot.

First, try the latest release -- 4.8.12. If this bug is actual for 4.8.12, please provide screenshot of frozen mc. What terminal emulator do you use?

comment:4 follow-up: ↓ 5 Changed 5 years ago by nrbrtx

In Description and comments 1 and 2 I used gnome-terminal 2.32.1-r1. Screenshot is very simple, it looks like normal Copy process, but all progress-bars and text do not update.
I tested 4.8.11 again using

  • TERM=linux (init 1),
  • xterm 297
  • gnome-terminal 2.32.1-r1

I can't reproduce the bug. It's strange.

Now I updated mc to 4.8.12. I copied the same big amount of files using:

  • TERM=linux (init 1),
  • xterm 297
  • gnome-terminal 2.32.1-r1

I can't reproduce the bug.

Thank you for pointing to possible terminal emulator problem.
I remembered, that have had some problems with gnome-terminal before. For example, if I run emerge world (compilation of whole Gentoo system with long text output), I got problems with scrolling in gnome-terminal. If I rotate mouse wheel the auto-scroll functionality restored.

So I think that the problem is in gnome-terminal (or GTK+ VTE widget).
Let's close this bug.

If I get MC hung/frozen/stalled again in different terminal I'll write here the details.

Thank you!

Changed 5 years ago by nrbrtx

mc screenshot during Copy (looks as copy is paused)

comment:5 in reply to: ↑ 4 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted

Replying to nrbrtx:

Let's close this bug.

Ok.

Note: See TracTickets for help on using tickets.