Ticket #3219 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Switching the viewer Raw/Parse mode stopped working

Reported by: hkmaly Owned by: andrew_b
Priority: major Milestone: 4.8.13
Component: mcview Version: 4.8.9
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master


Since 4.8.9, the switching between Raw/Parse? mode is not working for me.

On "normal" file (that is, text file which probably lack any magic) pressing F8 make both the content and filename completely disappear.

On gzipped file, if started the view in "raw" mode, pressing F8 will change to "parse". Additional pressing of F8 will change the text on the bottom bar, but doesn't change the view (it only resets position). If starting the view in "parse" mode, pressing F8 will not work from start (although first press will change the top status line) - again, the bottom bar changes but view doesn't.

I suspect it's related to [2968].

Current mc version:

GNU Midnight Commander 4.8.11
Built with GLib 2.32.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Root directory: /home2/hkmaly

[System data]

Config directory: /etc/mc/
Data directory: /usr/share/mc/
File extension handlers: /usr/libexec/mc/ext.d/
VFS plugins and scripts: /usr/libexec/mc/

extfs.d: /usr/libexec/mc/extfs.d/
fish: /usr/libexec/mc/fish/

[User data]

Config directory: /home2/hkmaly/.config/mc/
Data directory: /home2/hkmaly/.local/share/mc/

skins: /home2/hkmaly/.local/share/mc/skins/
extfs.d: /home2/hkmaly/.local/share/mc/extfs.d/
fish: /home2/hkmaly/.local/share/mc/fish/
mcedit macros: /home2/hkmaly/.local/share/mc/mc.macros
mcedit external macros: /home2/hkmaly/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /home2/hkmaly/.cache/mc/

'--prefix=/usr' '--build=i686-pc-linux-gnu' '--host=i686-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--disable-silent-rules' '--disable-dependency-tracking' '--enable-nls' '--enable-vfs' '--enable-vfs-undelfs' '--enable-charset' '--without-x' '--enable-vfs-smb' '--disable-vfs-sftp' '--enable-aspell' '--with-gpm-mouse' '--with-screen=slang' '--with-internal-edit' '--disable-mclib' '--disable-tests' '--with-homedir=XDG' 'build_alias=i686-pc-linux-gnu' 'host_alias=i686-pc-linux-gnu' 'CFLAGS=-O2 -mtune=k8 -march=k6 -fomit-frame-pointer -pipe' 'LDFLAGS=-Wl,-O1 -Wl,--as-needed'

(I first noticed on this version of mc, then tried other versions and 4.8.8 worked normally while 4.8.9 didn't. Also 4.8.12 didn't.)

Change History

comment:1 Changed 10 years ago by hkmaly

I meant #2968, not [2968] ...

comment:2 Changed 10 years ago by hkmaly

Also possibly related to #2090 ... which reminds me I should clarify that by "opening in raw mode" I mean opening with the "last used mode" set to "raw", not the shift-F3 version ... if I open the file with shift-F3, it behaves the same way as normal file - that is, it shows the raw version and when I press F8 both file content and top line disappears.

comment:3 Changed 10 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Version changed from master to 4.8.9
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.13


Version 0, edited 10 years ago by andrew_b (next)

comment:4 Changed 10 years ago by hkmaly

comment:5 Changed 10 years ago by slavazanko

  • Votes for changeset set to slavazanko
  • Branch state changed from on review to approved

comment:6 Changed 10 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:7 Changed 10 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.