Ticket #3182 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

ncurses only supports single lines

Reported by: egmont Owned by:
Priority: minor Milestone:
Component: mc-skin Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

The ncurses build doesn't support double lines (they get converted to single lines), and doesn't support other strange line drawing characters one might experiment with (they get converted to replacement letters), including (but not limited to):

  • double horizontal, single vertical corner: ╒ (U+2552)
  • thick corner: ┏ (U+250F)
  • rounded corner: ╭ (U+256D)

In a graphical terminal with UTF-8 support, there shouldn't be a reason not to support any Unicode character. The slang build is able to display any of these without problems.

In ticket:2165#comment:10 andrew_b expressed his concerns about moving the single/double lines stuff from skins to the engine because it kills creativity. I wanted to be creative and create a skin where the horizontal lines are double lines and the vertical ones are single ones. With ncurses it just doesn't work. Currently only single lines are supported by the ncurses build.

Change History

comment:1 Changed 6 years ago by egmont

  • Priority changed from major to minor
  • Component changed from mc-core to mc-skin

comment:2 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Version master deleted
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3158.

Note: See TracTickets for help on using tickets.