Ticket #3159 (assigned enhancement)

Opened 4 years ago

Last modified 4 months ago

Skin files: fix badly chosen keywords

Reported by: egmont Owned by: andrew_b
Priority: minor Milestone: 4.8.21
Component: mc-skin Version: 4.8.11
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:


Inspired by #2920 I started adding comments to default.ini. But it would be better if the names were more self-explanatory so we needed fewer comments.

I propose to change at least these names:

gauge -> progressbar (seems people have no clue what gauge could stand for)
reverse -> currentdir (keyword should describe the role, not the look)
[core] disabled -> [dialog] disabled (or "ddisabled" with double d for consistency?), it's only used in dialogs
helpslink -> helpselectedlink

Change History

comment:1 Changed 18 months ago by zaytsev

  • Owner set to andrew_b
  • Status changed from new to assigned
  • Milestone changed from Future Releases to 4.8.19

comment:2 Changed 14 months ago by egmont

See #3759 for a few more.

comment:3 Changed 14 months ago by egmont


[editor] -> editbold: just like reverse, the name should describe the role (search result) rather than look.

[editor] -> bookmarkfound: refers to technical implementation rather than user visible role. It's for highlighting search results at "find all". Nowhere does the UI say it has anything to do with bookmarks. It's irrelevant that the source code piggybacks on the same engine.

Some names duplicate the section name (e.g. [editor] -> editstuff, [menu] -> menuwhatever), some others don't (e.g. [diffviewer] -> added). The latter makes more sense to me; if the names are prefixed with the section name then why do we have sections?

comment:4 Changed 4 months ago by zaytsev

  • Milestone changed from 4.8.20 to 4.8.21
Note: See TracTickets for help on using tickets.