Ticket #3153 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

"make" after a local "git commit" reconfigures everything

Reported by: egmont Owned by:
Priority: minor Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Check out the git version, compile it.

Do some changes, run "make". It finishes in a couple of seconds, as expected.

Do a local "git commit" to save the changes.

Type "make" again.

Expected behavior: shouldn't take more than 1-2 seconds to compile. (It's okay to recompile one or two object files and to relink, since mc knows its own git version.)

Actual behavior: it reconfigures and recompiles everything, taking 1m20s on my machine. Of this, approx 30s is the configure, and 50s is the make. By the way, I do have ccache installed, if I do a "make; make clean; time make" then the last step finishes in about 30s. So for whatever reason something important changes in some file that's included everywhere, causing tons of ccache misses.

The beginning of make's output after a git commit:

make  all-recursive
make[1]: Entering directory `/home/egmont/mc'
/bin/bash ./config.status --recheck
running CONFIG_SHELL=/bin/bash /bin/bash ./configure --prefix=/tmp/MC --no-create --no-recursion
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes

Change History

comment:1 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2252.

comment:2 Changed 4 years ago by mooffie

On my computer (Pentium 4), 'configure' takes ~2 minutes and 'make' takes ~9 minutes.

Note: See TracTickets for help on using tickets.