Ticket #3129 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

wrong syntax highlighting for some perl code

Reported by: vsespb Owned by:
Priority: minor Milestone:
Component: mcedit Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

in the following valid perl code

use strict;
use warnings;
use Data::Dumper;
my $s = \"somestring";
print Dumper($s);

mcedit does not see closing quote of somestring.
same for singlequotes.

GNU Midnight Commander 4.8.1
Built with GLib 2.31.20
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Change History

comment:1 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2142.
Please use search before create tickets.

comment:2 Changed 8 years ago by egmont

Just FYI: http://www.perlmonks.org/?node_id=663393 [Perl Cannot Be Parsed: A Formal Proof]

Note: See TracTickets for help on using tickets.