Ticket #3110 (closed defect: wontfix)

Opened 7 years ago

Last modified 7 years ago

MC kicks me off after entering mc

Reported by: kdfwennes Owned by:
Priority: major Milestone:
Component: mc-tty Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Dear Sir or Madam,

after I installed MC with apt-get install mc on Debian, i tried
to start the program wich mc. But it didn't
start but shutdown the whole program.

I always received the following message:

An unsupported escape sequence is detected.
ESC [1015h

What can I do to start the program?

Kind regards,
Joerg

Attachments

Midnightcommander - Bug.PNG (11.3 KB) - added by kdfwennes 7 years ago.
Midnightcommander - Bug1.PNG (91.9 KB) - added by kdfwennes 7 years ago.

Change History

Changed 7 years ago by kdfwennes

Changed 7 years ago by kdfwennes

comment:1 follow-up: ↓ 2 Changed 7 years ago by egmont

This is related to the extended mouse click support, introduced by #2662 and #2956. I'm sure it's not only MC but also some more applications (e.g. vim, emacs, lynx...) that cause your terminal to crash, more and more by time as mainstream applications add support for extended mouse coordinates.

I'd say it's not a bug in MC and the right place to fix is not MC. It's your Poderosa terminal emulator that needs to be fixed. Given that the latest release is 7 years old, I'd consider abandoning it and choosing a different one (such as PuTTY).

It is of course easily possible to modify MC's source not to emit this code and then it'll be okay for you, or use the appropriate command line option to disable mouse support completely, but it's a partial workaround (other apps will still cause it to crash) applied to the wrong component.

In my opinion, any terminal emulator that crashes on an unknown escape rather than ignoring it is not (and should not be) supported.

Last edited 7 years ago by egmont (previous) (diff)

comment:2 in reply to: ↑ 1 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-tty
  • Type changed from enhancement to defect
  • Resolution set to wontfix
  • Milestone Future Releases deleted

Egmont, thanks for explanation! We agree with your opinion.

Note: See TracTickets for help on using tickets.