Ticket #3082 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

long timeout on startup

Reported by: nadvornik Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.8.10
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

mc calls gethostbyname() at least 6 times on startup. When there is some problem with DNS, it can lead to very long timeouts (like 5 minutes).

The attached patch reduces the number of gethostbyname calls to one.

It could be further improved by calling the smbfs initialization only if the smbfs is really used.

See also
https://bugzilla.novell.com/show_bug.cgi?id=824729

Attachments

mc-startup-timeout.patch (1.2 KB) - added by nadvornik 9 years ago.

Change History

Changed 9 years ago by nadvornik

comment:1 Changed 9 years ago by andrew_b

  • Component changed from mc-core to mc-vfs

This is definitly WONTFIX because of #1.

comment:2 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #40.

Note: See TracTickets for help on using tickets.