Ticket #3081 (closed enhancement: duplicate)

Opened 7 years ago

Last modified 7 years ago

mcedit command to copy to X11 clipboard

Reported by: pfalcon Owned by:
Priority: major Milestone:
Component: mcedit Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

With nice enhancements to XTerm paste, it would be nice to have mc-internal command to copy to X11 clipboard. There's no replacement for that by selecting console text and using terminal emulator copy command. Consider for example that with visible tabs/spaces it won't be usable at all (and that's cool feature of mcedit which I have all the time, hope other folks who work with multiple codebases and projects either). Even if it's not on, copying via termemu will not preserve tabs, and taht's again important when working with multiple projects with different codestyles.

Finally, mcedit clipfile could offer limited workaround (when copying from mcedit to mcedit, but what about copying to other apps/other machines?) - but even that has issues: #3080.

So, direct X11 clipboard is really needed to make mcedit completely comfortable to work in contemporary environment. And the issue is two-fold: first technically implement that, and then assign good key combo to it. Ctrl+Alt+C seems like both doable and intuitive enough (with Ctrl+Shifc+C being gnome terminal, etc. Copy).

Change History

comment:1 Changed 7 years ago by ossi

implemented long ago as #30. and of course i was right in my comment 20. ;)

comment:2 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #30.

comment:3 Changed 7 years ago by pfalcon

Err, I wanted then to rephrase this ticket to be elaboration of what was done for #30. Do you really want 3-yars old #30 to be reopened instead?

comment:4 Changed 7 years ago by pfalcon

  • Milestone set to Future Releases

@andrew_b: No reply, then my preference is actually not to resurrect 3-year old bug: I don't challenge that it's implemented and closed. I have ideas how to elaborate X11 Copy/Paste? implementation, and rather would have this as a separate ticket (xref to #30 are good of course). As it's not possible to edit description of this bug, I created new one at #3083.

@ossi: Thanks for the pointer! You were right of course in your comment, and it doesn't take a psychologist or UI interaction scientist to predict that if some basic feature is not immediately works/visible, it won't be found. So let's look how we can improve on #30.

comment:5 Changed 7 years ago by pfalcon

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.