Ticket #3058 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

nano editor started with incorrect options

Reported by: schuay Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

This bug report is copied from https://bugs.archlinux.org/task/36131?project=5&dev=3843:

Description:
If you set [mc] external editor Nano. That [mc] runs it with the wrong parameters "%filename +%lineno". while the Nano requires reverse order "Usage: nano [OPTIONS] [[+ LINE, COLUMN] FILE] ...".

Additional info:
mc-4.8.9

it is treated with:
edit /usr/share/mc/mc.lib
instead of
...
nano=%filename +%lineno
...

should be
...
nano=+%lineno %filename
...

Steps to reproduce:
1) set external editor Nano
2) open any file to edit
3) will open the file in nano
4) after close nano, will be opened "temp" file with name "+1" or same

Change History

comment:1 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Duplicate of #3044.

Note: See TracTickets for help on using tickets.