Ticket #3045 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

patch vfs becoming permanently stale

Reported by: mnk Owned by: andrew_b
Priority: major Milestone: 4.8.10
Component: mc-core Version: 4.8.9
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

I'm not 100% sure (as I haven't downgraded yet), but there has been a major regression between 4.8.8 and 4.8.9 with patch vfs (at least I've only found it in this vfs, but I haven't used others in such way).

The workflow:

  • create a patch
  • enter vfs, delete a few files, leave vfs
  • modify the patch externally (i.e. delete a single chunk from a file)
  • reenter vfs

Not only vfs doesn't get updated (as this had happened before too), but now vfs can't be force-released from vfs dialog.

On a related note: I might be wrong here, but that dialog seems to be only one, that getting closed by Down Arrow - that's counter-intuitive and inconsistent.

Change History

comment:1 Changed 6 years ago by mnk

...I've obviously meant "by Right Arrow".

comment:2 in reply to: ↑ description ; follow-up: ↓ 3 Changed 6 years ago by andrew_b

Replying to mnk:

The workflow:

  • create a patch
  • enter vfs, delete a few files, leave vfs
  • modify the patch externally (i.e. delete a single chunk from a file)

How? Using internal editor or not?

  • reenter vfs

What do after this step?

Not only vfs doesn't get updated (as this had happened before too),

Yes, this is #62.

but now vfs can't be force-released from vfs dialog.

You just cannot release vfs forced if you make this within that vfs. You must leave vfs and then you can release it.

On a related note: I might be wrong here, but that dialog seems to be only one, that getting closed by Down Arrow - that's counter-intuitive and inconsistent.

"Right" key is an equivalent to "Enter" one, it moves you into selected vfs. Btw, this behavior exists more than 15 years.

comment:3 in reply to: ↑ 2 Changed 6 years ago by mnk

Replying to andrew_b:

Replying to mnk:

The workflow:

  • create a patch
  • enter vfs, delete a few files, leave vfs
  • modify the patch externally (i.e. delete a single chunk from a file)

How? Using internal editor or not?

Usually using internal editor.

  • reenter vfs

What do after this step?

Notice it's stale (or not and mess up the patch then). If notice, leave vfs and try to release it.

Not only vfs doesn't get updated (as this had happened before too),

Yes, this is #62.

but now vfs can't be force-released from vfs dialog.

You just cannot release vfs forced if you make this within that vfs. You must leave vfs and then you can release it.

Well, I thought it was obvious (from the context) I leave the vfs before releasing it.

On a related note: I might be wrong here, but that dialog seems to be only one, that getting closed by Down Arrow - that's counter-intuitive and inconsistent.

"Right" key is an equivalent to "Enter" one, it moves you into selected vfs. Btw, this behavior exists more than 15 years.

I've been using mc for a little over 10 years and this never became any less confusing and annoying.
What would be expected is something more alike to "Search Results" dialog, where Right Arrow moves the cursor to dialog's buttons.

comment:4 Changed 6 years ago by andrew_b

I cannot reproduce this bug with recent master snapshot (4.8.9-4-g5fdd102) or I'm doing something wrong.

Would you try reproduce this bug with 4.8.9-4-g5fdd102 yourself?

comment:5 follow-up: ↓ 6 Changed 6 years ago by mnk

Well, I've just took 8cb80dcc9c0c2f36111dd439f3e415cec58f7ffa and 4f1801ca11a50187b51916813a3a331e4e3190ba
and the problem seems fixed (though links like changeset/8cb80dcc9c0c2f36111dd439f3e415cec58f7ffa?format=diff&new=8cb80dcc9c0c2f36111dd439f3e415cec58f7ffa save with \r\n endings - bit quirky).

Regardless of that, is the change of the inconsistent vfs dialog behavior open for discussion ?

comment:6 in reply to: ↑ 5 Changed 6 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Component changed from mc-vfs to mc-core
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.10

Replying to mnk:

Regardless of that, is the change of the inconsistent vfs dialog behavior open for discussion ?

OK, this behavior is changed to be consistent with other dialogs.

Branch: 3045_hotlist_right_key.
changeset:7d28512890a94e36b3e444d85bee0c4c542050f0

comment:7 Changed 6 years ago by angel_il

  • Votes for changeset set to angel_il

comment:8 Changed 6 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko
  • Branch state changed from on review to approved

comment:9 Changed 6 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il slavazanko to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:10 Changed 6 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.