Ticket #3030 (closed enhancement: duplicate)

Opened 6 years ago

Last modified 5 years ago

no way to append own (~/.config/...) Syntax to packaged Syntax

Reported by: yury_t Owned by:
Priority: minor Milestone:
Component: mcedit Version: 4.8.8
Keywords: Cc:
Blocked By: #1677 Blocking:
Branch state: no branch Votes for changeset:

Description

There's no (easily discernible) way to include one's own Syntax rules in addition to the package's ('system') Syntax rules.

First thing, personal and package's Syntax are mutually exclusive: on Linux, either ~/.config/mc/mcedit/Syntax or /usr/share/mc/syntax/Syntax works, but not both.

Second thing, seems Syntax file cannot be included from another Syntax file. Trying to put into personal Syntax this...

file .\* refer to package's Syntax
include /usr/share/mc/syntax/Syntax

...effects in error on the first 'file' line in package's Syntax.

Can anything be done?

Change History

comment:1 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Duplicate of #1984.

comment:2 Changed 6 years ago by yury_t

Well, I can't make you do anything, but that's not a duplicate of a feature request (3 years old, anyway). That's config files not working properly, detracting from product's user value.

Last edited 6 years ago by yury_t (previous) (diff)

comment:3 Changed 5 years ago by gavenkoa

  • Type changed from defect to enhancement
  • Blocked By 1677 added

Seems that include or source or import keyword help.

Another way - use /xxx.d/ directory and load files on name order (NN-xxxx patterns) see #1677. This look more promising.

But before do this it is necessary define read priority order or conflict resolution strategy (in documentation). See arguments in #3191.

Note: See TracTickets for help on using tickets.