Ticket #2984 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Bogus file ownership reported by FISH if the remote user does not exists locally

Reported by: ply Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Present in 4.8.7-116-g5cbef94, too.

Steps to reproduce:

  • Choose a remote host with an additional user account
  • Use the 'shell link' function to open a directory on that host
  • Remote files owned by locally nonexistent user are reported as yours

This is VERY confusing. Listing the same directory over an NFS mount shows those ownerships as numeric UIDs as expected. The problem seems to be the vfs_finduid function in lib/vfs/utilvfs.c, which looks up textual names, and if not found, then returns the current user's UID.

Of course, transferring symbolic account names have its own advantages, but then mapping failures should be handled more sanely, such as mapping to nobody instead.

Change History

comment:1 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Duplicate of #1407.

Note: See TracTickets for help on using tickets.