Ticket #2973 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

extfs p7zip speed

Reported by: JGPFWQ Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

version: all version; all configurations
reproducible: always

steps to reproduce

first

create an archive of a large directory(hundreds of gigabytes with millions of files and subdirs) with 7za and mad compression (something like: 7za -t7z -mx=7 -m9=lzma2 -mhc=on -ms=on -mfb=65536 directory archive.7z)

second

open the archive with mc and dive into a subdirectory.

tag some files and directories ( <em> O </em> or inser).

third

do something on the tagged files such as deletion (F8) or copy (F5)

consequence

extfs launch 7z for each file resulting in asking an action for one file at time, resulting in a command like 7z d archive each file contained in tagged subdirectories.
this might look normal but I will explain what it implies:

  • When you delete/extract a file on an archive like this, 7z "parse" the whole file (it take some minutes on my machine).


  • Then it perform the asked actions

This means 7z parse the archive several times whereas it could be done once

workaround

p7zip support with all path to each file listed on the command line.It can also delete subdirectories directly (without deleting it's content before)

When some files are in yellow and an operation is launched on them the (7z-)archiver should receive the whole file list with their respective leading path relative to archive as 7zFm do with 7zG

Change History

comment:1 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset master deleted
  • Resolution set to duplicate
  • Component changed from mc-core to mc-vfs
  • Version changed from version not selected to master
  • Milestone Extra parameters for searching and selecting files deleted
  • Keywords extfs 7z p7zip slow tagged yellow removed
  • Type changed from enhancement to defect

Duplicate of #3.

Note: See TracTickets for help on using tickets.