Ticket #2904 (closed enhancement: duplicate)

Opened 7 years ago

Last modified 3 years ago

Show extended attributes in Info window

Reported by: gotar Owned by:
Priority: minor Milestone:
Component: mc-core Version: master
Keywords: xattrs, ACLs Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

ctrl-x i window should provide additional file information, that can be obtained by getfacl, getfattr and maybe getcap. Contrary to manipulating these data, this seems to be easy task.

Change History

comment:1 Changed 7 years ago by gotar

  • Blocking 2928 added

(In #2928) Proper detection of write access requires multiple checks (not only directory mode, but also xattrs and possibly other things). Until mc has decent ACL support this would only misguide people.

comment:2 Changed 7 years ago by andrew_b

  • Blocked By 1852 added

comment:3 Changed 3 years ago by zaytsev

  • Blocking 2928 removed
  • Blocked By 1852 removed

comment:4 follow-up: ↓ 5 Changed 3 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #3713.

comment:5 in reply to: ↑ 4 Changed 3 years ago by boruch

Replying to zaytsev:

Closed as duplicate of #3713.

Better, I think: Duplicated -BY- #3727.

I really like this idea and am willing to add it to the patch I already provided for #3727 once the idea is approved / accepted.

comment:6 Changed 3 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.