Ticket #2899 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

shell link copy files eats all of /tmp

Reported by: lukdk Owned by:
Priority: major Milestone:
Component: mc-vfs Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hello,

When using a shell link to a remote host to copy multiple files, it is not possible to copy more than the size of your /tmp, even though none of the files is bigger than your /tmp max size.

deleting the /tmp/mc-[username]/fish-files only happens after all files are being copied. The temp file should be deleted right after the copy of that single file is done.

example:
more than 3 files of 900MB on /mnt/data
/tmp on a partition of 2 GB

when trying to copy the files to a remote host only the first 2 files will succeed. The /tmp partition will be 100% full. MC gives an error regarding disk space. When choosing to skip all, it will continue with the rest of the files, creating 0byte files on the remote host.

~/mc/bin $ ./mc -V
GNU Midnight Commander 4.8.6
Built with GLib 2.30.3
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

I've also tested this with an older version and had exactly the same issue

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Version 4.8.6 deleted
  • Milestone Future Releases deleted
  • Keywords shell link copy removed
  • Resolution set to duplicate

Duplicate of #77.

Note: See TracTickets for help on using tickets.