Ticket #2880 (closed enhancement: duplicate)

Opened 7 years ago

Last modified 7 years ago

Simplify and extend viewing of audio/video files

Reported by: birdie Owned by:
Priority: major Milestone: 4.8.6
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Mplayer always gives more information than even specialized (ogg/mod/etc) viewers can show, so, please, change the way information about audio and video files is retrieved:

        if mplayer -v &>/dev/null; then
            mplayer -identify -vo null -ao null -frames 0 "${MC_EXT_FILENAME}" 2>&1 | sed -n 's/^ID_//p'
        else
            echo "*** Please, install mplayer to get extended information about this file. ***"
            file "${MC_EXT_FILENAME}"
        fi

'sed' is there to remove the unneeded prefix "ID_" in the fields than an audio/video file contains.

Change History

comment:1 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2767.

Note: See TracTickets for help on using tickets.