Ticket #2851 (reopened defect)

Opened 7 years ago

Last modified 2 years ago

cannot copy file from iso created with mkisofs when Joliet without RockRidge used

Reported by: ctmp1 Owned by:
Priority: major Milestone: 4.8.16
Component: mc-vfs Version: master
Keywords: Cc: gotar@…
Blocked By: #3537 Blocking:
Branch state: no branch Votes for changeset:

Description

mc creates file of zero length instead of extracting file from mkisofs-created iso images containing Joliet without RockRidge extension

Steps to reproduce:

  1. create iso image with Joliet but without RockRidge
mkisofs -J -o test.iso /etc/passwd
  1. run
/usr/libexec/mc/extfs.d/iso9660 copyout test.iso passwd passwd

Expected non-zero size passwd file, got file of zero size

The image created by mkisofs doesn't contain versions in filenames unlike images created by Nero 7 (windows). The bug was probably introduced with #2471

for mkisofs-generated image:

$ isoinfo -J  -l -i test.iso

Directory listing of /
d---------   0    0    0            2048 Jul 19 2012 [     29 02]  . 
d---------   0    0    0            2048 Jul 19 2012 [     29 02]  .. 
----------   0    0    0            2044 Jun 28 2012 [     30 00]  passwd

$ isoinfo -d -i test.iso
CD-ROM is in ISO 9660 format
System id: LINUX
Volume id: CDROM
Volume set id: 
Publisher id: 
Data preparer id: 
Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993 E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT TEAM
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 181
Joliet with UCS level 3 found
NO Rock Ridge present

for Nero 7-generated image:

$ isoinfo -J  -l -i nero7.iso

Directory listing of /
d---------   0    0    0            2048 Jul 19 2012 [     22 02]  . 
d---------   0    0    0            2048 Jul 19 2012 [     22 02]  .. 
----------   0    0    0           19794 Apr 17 2009 [     25 00]  xxx.pdb;1
$ isoinfo -d -i nero7.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: ________
Volume set id: 
Publisher id: 
Data preparer id: 
Application id: NERO BURNING ROM
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 600
Joliet with UCS level 3 found
NO Rock Ridge present

The simple solution would be replacement of iso9660 vfs with u7z. As bonus 7-zip can read iso images created by deepburner and winoncd 3.6 (they are Joliet with UCS level 1) and images created with mkisofs without -R and -J options at all

Software versions:
mc-4.8.4-0.git20120630.fc17.R.i386
genisoimage-1.1.11-10.fc17.i686

Change History

comment:1 Changed 7 years ago by gotar

  • Cc gotar@… added

comment:2 follow-up: ↓ 3 Changed 4 years ago by and

I can confirm this ticket is resolved by #3537

non Rock Ridge iso can be handled by mc extfs now.

comment:3 in reply to: ↑ 2 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Version changed from version not selected to master
  • Resolution set to fixed
  • Milestone changed from Future Releases to 4.8.16

Replying to and:

I can confirm this ticket is resolved by #3537

Thanks!

non Rock Ridge iso can be handled by mc extfs now.

Ok, closed.

comment:4 Changed 4 years ago by zaytsev

  • Blocked By 3537 added

comment:5 Changed 2 years ago by marcelpaulo

  • Status changed from closed to reopened
  • Resolution fixed deleted

Somehow this issue crept back in as of mc version 4.8.19-1. When I ran the original steps:

mkisofs -J -o test.iso /etc/passwd
/usr/libexec/mc/extfs.d/iso9660 copyout test.iso passwd passwd

this is the result:

paulo@monk:~/tmp$ ls -l
total 364
-rw-rw-r-- 1 paulo paulo      0 nov  2 00:29 passwd
-rw-rw-r-- 1 paulo paulo 372736 nov  2 00:28 test.iso

I'm running mc version 4.8.19-1 on Xubuntu 17.10.

comment:6 follow-up: ↓ 7 Changed 2 years ago by andrew_b

Seems isoinfo was changed since #2471. It doesn't append ";1" to file names anymore.
I wonder when it happened.

comment:7 in reply to: ↑ 6 Changed 2 years ago by andrew_b

Replying to andrew_b:

Seems isoinfo was changed since #2471. It doesn't append ";1" to file names anymore.
I wonder when it happened.

Seems it is isoinfo@cdrtools vs. isoinfo@cdrkit. isoinfo@cdrtools added (or still adds, I don't know) ";1" to file names but isoinfo@cdrkit doesn't. What we should do?

Note: See TracTickets for help on using tickets.