Ticket #2840 (closed defect: fixed)

Opened 7 years ago

Last modified 3 years ago

[WIKI] compilation requirements

Reported by: leadman Owned by:
Priority: minor Milestone:
Component: documentation Version: master
Keywords: wiki Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

During compilation of mc, as I was asked in ticket #2635, I found that one of build dependencies is missing the list. As I am not able to edit this wiki page, and can't add this dependency, I have created a ticket.
Please add "autopoint" program/package as dependency on wiki page:
https://www.midnight-commander.org/wiki/doc/buildAndInstall/req

Change History

comment:1 Changed 7 years ago by leadman

Also please add libssh2-1-dev package as a dependency (at least on Ubuntu 12.04)

comment:2 follow-up: ↓ 3 Changed 7 years ago by slavazanko

Please add "autopoint" program/package as dependency on wiki page:

is autopoint stand-alone application? I mean, is autopoint have own package? In my case autopoint included into gettext-devel RPM-package.

Also please add libssh2-1-dev package as a dependency (at least on Ubuntu 12.04)

We already have the 'libssh2-dev' dependency on req page. What mean '1' in your 'libssh2-1-dev' package name? Is this number static or may be changed in future? Can be 'libssh2-1-dev' package same as 'libssh2-dev'?

comment:3 in reply to: ↑ 2 Changed 7 years ago by leadman

Replying to slavazanko:
[cut]

is autopoint stand-alone application? I mean, is autopoint have own package? In my case autopoint included into gettext-devel RPM-package.

Yes, it is a package:

root@esp-patben-lin:/# apt-cache policy autopoint
autopoint:
  Zainstalowana: 0.18.1.1-5ubuntu3
  Kandydująca:   0.18.1.1-5ubuntu3
  Tabela wersji:
 *** 0.18.1.1-5ubuntu3 0
        500 http://pl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

[cut]

We already have the 'libssh2-dev' dependency on req page. What mean '1' in your 'libssh2-1-dev' package name? Is this number static or may be changed in future? Can be 'libssh2-1-dev' package same as 'libssh2-dev'?

I have no clue what does '1' mean. My OS is Debian based (Ubuntu 12.04) and it seems to me that 'libssh2-1-dev' and 'libssh2-dev' packages are not the same. Moreover, I do not have 'libssh2-dev' package at all:

root@esp-patben-lin:/# apt-cache policy "^libssh2.*"
libssh2-php:
  Zainstalowana: (brak)
  Kandydująca:   0.11.2-1
  Tabela wersji:
     0.11.2-1 0
        500 http://pl.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
libssh2-0-dev:
  Zainstalowana: (brak)
  Kandydująca:   (brak)
  Tabela wersji:
libssh2-1-dbg:
  Zainstalowana: (brak)
  Kandydująca:   1.2.8-2
  Tabela wersji:
     1.2.8-2 0
        500 http://pl.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
libssh2-1-dev:
  Zainstalowana: 1.2.8-2
  Kandydująca:   1.2.8-2
  Tabela wersji:
 *** 1.2.8-2 0
        500 http://pl.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status
libssh2-1:
  Zainstalowana: 1.2.8-2
  Kandydująca:   1.2.8-2
  Tabela wersji:
 *** 1.2.8-2 0
        500 http://pl.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Maybe it would be enough to add some comment, that for Ubuntu, one should install 'libssh2-1-dev' and 'autopoint' packages?

comment:4 follow-up: ↓ 5 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to fixed

comment:5 in reply to: ↑ 4 Changed 7 years ago by leadman

Replying to andrew_b:
Hi andrew_b,
why did you closed this, while it is still not fixed? The wiki still shows old requirements.

comment:6 follow-up: ↓ 7 Changed 7 years ago by andrew_b

Please quote here from wiki page what is still wrong.

comment:7 in reply to: ↑ 6 Changed 7 years ago by leadman

Replying to andrew_b:

Please quote here from wiki page what is still wrong.

I don't know how to quote missing text. And as I wrote initially, the wiki lacks of "autopoint" and "libssh2-1-dev" package as dependencies here:
https://www.midnight-commander.org/wiki/doc/buildAndInstall/req

comment:8 follow-up: ↓ 9 Changed 7 years ago by andrew_b

Just try find 'autopoint' and 'libssh2-1-dev' words in that page.

comment:9 in reply to: ↑ 8 Changed 7 years ago by leadman

Replying to andrew_b:

Just try find 'autopoint' and 'libssh2-1-dev' words in that page.

I am sorry, I promptly looked at the 'Name" column and haven't noticed. Mea Culpa.

comment:10 Changed 3 years ago by andrew_b

  • Milestone Documentation deleted
Note: See TracTickets for help on using tickets.